采用ubuntu系统来安装tensorflow

from http://www.cnblogs.com/ljy2013/p/5491680.html

 

最近在学习google新开源的深度学习框架tensorflow。发现安装它的时候,需要依赖python2.7.X;我之前一直使用的linux是centos。而centos不更新了,里面的自带的python一般都是python2.6以下的。不仅如此,系统里面很多组件又依赖python2.6,所以导致你都不能替换掉它。无奈之下,选择ubuntu了。下面介绍一下使用ubuntu安装tensorflow遇到的一些问题。

1、ubuntu无法用Winscp连接

解决办法:

(1)、采用桥接的方式进行上网(由于是用虚拟机安装的操作系统)

(2)、利用ps -e  |grep ssh  查看是否有sshd进程开启。如果没有则需要安装openssh-server

安装的方式:sudo apt-get install openssh-server

启动相应的进程:/etc/init.d/ssh start

(3)、此时需要reboot系统

(4)、由于ubuntu最初root的用户是没有被激活的,所以需要通过修改root用户密码来激活root用户。

完成即可连接了。

2、安装tensorflow。

由于我的ubuntu是最新版的(ubuntu-16.04-desktop-amd64),里面自带的python是2.7.11。因此满足要求。由于tensorflow有三种安装方式,这里采用的是pip安装方式。下面开始安装tensorflow:

(1)首先安装pip

 sudo apt-get install python-pip python-dev

(2)利用pip安装tensorflow

sudo pip install --upgrade https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.8.0-cp27-none-linux_x86_64.whl

安装好了后,如下图所示:

根据上面黄色的提示,叫我升级pip:于是我就按照他的要求升级了,执行:pip install –upgrade pip

3、检验tensorflow是否安装成功

通过下面一段代码来测试tensorflow是否安装成功:

$ python
...
>>> import tensorflow as tf
>>> hello = tf.constant('Hello, TensorFlow!')
>>> sess = tf.Session()
>>> print(sess.run(hello))
Hello, TensorFlow!
>>> a = tf.constant(10)
>>> b = tf.constant(32)
>>> print(sess.run(a + b))
42
>>>
下面是我执行的结果如下图所示:

4、安装python-numpy ,python-scipy,python-matplotlib

sudo apt-get install python-numpy

sudo apt-get install python-scipy

sudo apt-get install python-matplotlib

验证是否安装成功:(如下图所示)

 

分享到:更多 ()